WPA Recover 0.5a1

In questa versione si introduce il supporto dello scan tool su mac. Leggete attentamente l’ultima parte del file settings.ini. Viene anche utilizzato uno script leggermente diverso per rilevare le interfaccie su linux.

In questa versione ci saranno sicuramente nuovi bug quindi vi prego segnalateli se li trovate.

CHANGELOG

Versione 0.5a1

  • Supporto (ALPHA) dello Scan Tool su MAC (ringrazio Mauro Ferratello)
  • Pulizia e ottimizzazzione del codice
  • Cambiati gli script per il funzionamento su Linux (ALPHA)
  • Fix potenziale NullPointerException utilizzando jWlanScan

DOWNLOAD LINK WPA Recover 0.5a1

Questa voce è stata pubblicata in Java, WPARecover. Contrassegna il permalink.

18 risposte a WPA Recover 0.5a1

  1. Alessandro ha detto:

    Ciao seguo il tuo lavoro da un po e intanto ti ringrazio molto.
    Vorrei segnalarti che su macbook parte lo scan tool ma premendo scan non fa la scansione delle reti. Io ho mountain lion 10.8.4, ultima versione di java.
    grazie ancora!

    • vento041 ha detto:

      Lo scan tool su mac è ancora in alpha e dai commenti capisco che ha ancora bisogno di sistemazioni xD Sto facendo test e spero di mettere apposto tutto il più velocemente possibile🙂

      • Alessandro ha detto:

        Ok io ti ho solo scritto per cercare di aiutarti come posso🙂
        Visto che hai scritto che non puoi testare direttamente su mac il tool se vuoi che provi qualcosa in particolare chiedimi pure che ti faccio sapere!😉

    • vento041 ha detto:

      Visto che hai detto che ti sei proposto per qualche test (mhuahahauuhuauhuah) ti andrebbe di proare qualh comando da terminale?

    • vento041 ha detto:

      Prova ad eseguire i comandi :

      /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -s | grep : | sed ‘s/^ *//g’ | cut -d ” ” -f 1,2 | tr ” ” “\n”

      e :

      /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -s | grep :

      e dimmi l’output🙂

      • Alessandro ha detto:

        Dopo aver inserito il primo l’output è questo:

        usage: cut -b list [-n] [file …]
        cut -c list [file …]
        cut -f list [-s] [-d delim] [file …]
        usage: tr [-Ccsu] string1 string2
        tr [-Ccu] -d string1
        tr [-Ccu] -s string1
        tr [-Ccu] -ds string1 string2
        sed: 1: “‘s/^”: invalid command code ?

        Invece dopo aver inserito il secondo:

        TNCAP4D74A9 a4:b1:e9:4d:74:a9 -86 6 Y — WPA(PSK/TKIP/TKIP) WPA2(PSK/AES/TKIP)
        Alice-59870174 5c:33:8e:28:b3:55 -86 1 N — WEP
        FASTWEB-1-GQ72JRp7JhFe 64:87:d7:bc:05:24 -37 1 N IT WPA(PSK/TKIP/TKIP)

      • vento041 ha detto:

        Scarica questo (http://www.mediafire.com/?6zmgxfyihek3g8h) ed eseguilo col solito brutale java -jar😀 Grazzzie del supporto🙂

      • Alessandro ha detto:

        Ho provato piu volte a farlo partire ma non si avvia nulla… nessuna finestra, niente di niente… fammi sapere! p.s. il launcher è jar launcher, quello di default java…

      • vento041 ha detto:

        Fallo partire da terminale, il prog butta tutto in output li🙂

      • Alessandro ha detto:

        Nulla non va.
        Non vorrei essermi sbagliato, ho scaricato il tuo file e da terminale ho inserito:

        java -jar JavaApplication1.jar

        e con invio mi da:

        Error: Unable to access jarfile JavaApplication1.jar

      • vento041 ha detto:

        sei sulla stessa cartella in cui si trova il jar ?

      • Alessandro ha detto:

        Ok sono riuscito, scusa ma sbagliavo una cosa.
        Comunque l’output è:
        No-#-networks-#-found-#-
        No networks

        Però in realtà di reti ce ne sono almeno 3 qui dove sono.

      • Alessandro ha detto:

        Ho le notifiche nelle email delle risposte nei commenti sul tuo blog, quindi quando e se avrai altro da provare ecc… scrivimi pure che sono ben contento di poterti aiutare! 😉

  2. Alessandro ha detto:

    Ah aggiungo che ho provato entrambe le impostazioni che hai scritto nel file settings, ma non funziona lo stesso. Quando parli di flag sottostante, che va impostato ad uno, quale e dove intendi? grazie!

    • vento041 ha detto:

      Con flag sottostante intendo “CompatibilityMode”
      Pratiamente devi cambiare CompatibilityMode=0 in CompatibilityMode=1🙂

      • Alessandro ha detto:

        Intanto ti aggiorno anche sul fatto che pur mettendo compatibilitymode a 1 e cambiando la stringa non parte lo scan tool. Ho notato anche che il button di refresh e la relativa combobox nello scan tool risultano disabilitate e inutilizzabili.😉

      • vento041 ha detto:

        bottone combobox sono disabilitate volutamente

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...